Error while setting the lookup and publishing the workflow in Dynamics 365

Recently while trying to configure a Team in Assign step we were getting the below error

With following details (not much useful)

The only way we figured out to set that field was to first chagne the Entity in the Assign Drop down and then selecting the team in the lookup dialog bx.

Below we have changed the Entity to Brand (custom entity) from Lead and then changed it back to Lead and then tried setting the team from the lookup dialog box.

We were successful this time.

Or setting the lookup through quick search view instead of opening up the lookup dialog box as shown below

The other issue we were facing was while trying to publish the workflow we were getting the below errorà “The selected workflow has errors and cannot be published. Please open the workflow, remove the errors and try again.”

This we realized in one of the Check Condition steps we had the values repeated for one of the lookup field.

This was because the workflow was imported to the target environment and later the records of the lookup entity that is being referred were deleted and added back which eventually led to 2 duplicate values i.e. same display name and different GUID thing. (1 non-existing in that environment, but still there inside workflow step). Removing it fixed the issue and we were able to publish the workflow.

Hope it helps..


Author: Nishant Rana

I love working in and sharing everything about Microsoft.NET technology !

Share your thoughts

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google+ photo

You are commenting using your Google+ account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

w

Connecting to %s