Unable to Change Domain Logon Name error in CRM 2011.

Hi,

Recently got the below error while updating a record. It was surprising as we were just saving the record to which we had full access.

The good thing was that the log file had the correct message\information about the error

The error was because of access denied error while trying to write something to a text file inside plugin code.

Unhandled Exception: System.ServiceModel.FaultException`1[[Microsoft.Xrm.Sdk.OrganizationServiceFault, Microsoft.Xrm.Sdk, Version=5.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35]]: Access is denied.Detail:

<OrganizationServiceFault xmlns:i=”http://www.w3.org/2001/XMLSchema-instance&#8221; xmlns=”http://schemas.microsoft.com/xrm/2011/Contracts”&gt; <ErrorCode>-2147187707</ErrorCode>

<ErrorDetails xmlns:d2p1=”http://schemas.datacontract.org/2004/07/System.Collections.Generic&#8221; />

<Message>Access is denied.</Message>

<Timestamp>2011-11-02T14:13:28.7922199Z</Timestamp>

<InnerFault i:nil=”true” />

<TraceText>

[testPlugin: testPlugin.Class1]

[7e507fe4-3605-e111-9e2c-00155d2a49c7: testPlugin.Class1: Update of lead]

</TraceText>

</OrganizationServiceFault>

Few days back also one friend of mine was getting the same issue, however it was while importing the solution. Not sure how it was fixed for them. It might be some custom code throwing exception.

Bye.


Author: Nishant Rana

I love working in and sharing everything about Microsoft.NET technology !

4 thoughts on “Unable to Change Domain Logon Name error in CRM 2011.”

  1. Hi,
    I had the same problem, i solved it with the following:
    Change “AutoGroupManagementoff” value set to 1 (false) in your registry (HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSCRM)

    It fixed my issue, and the error is the same as above πŸ™‚

    Like

  2. Hi,

    I have the same issue. When I try to change the domain name or create a new user, I get the same unable to change domain logon name error.
    That error started when I, accidently, moved two AD Groups from one domain to another. Then I moved them back. The groups were UserGroup {f7ed63a3-e7c6-4a07-9c8b-5369506bcdd5} e ReportingGroup {f7ed63a3-e7c6-4a07-9c8b-5369506bcdd5}.
    Is there a workarround to solve this problem?
    thank you very much,
    Joao

    Like

Share your thoughts

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s